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Foreword
General
This manual describes the structure, function and operation of intelligent video surveillance
server (IVSS).

Model
8-HDD, 12-HDD, 16-HDD, and 24-HDD.

Safety Instructions
The following categorized signal words with defined meaning might appear in the Manual.
Signal Words

Meaning
Indicates a high potential hazard which, if not avoided, will result in

DANGER

death or serious injury.
Indicates a medium or low potential hazard which, if not avoided,

WARNING

could result in slight or moderate injury.
Indicates a potential risk which, if not avoided, could result in

CAUTION

property damage, data loss, lower performance, or unpredictable
result.
Provides methods to help you solve a problem or save you time.

TIPS

Provides additional information as the emphasis and supplement to
NOTE

the text.

Revision History
Version

Revision Content

Release Time

V2.1.0

Add video structuring, vehicle recognition, and
vehicle comparison functions.

April 2019

V2.0.1

Add attention in important safeguards and warnings.

January 2019

V2.0.0

Update figures of 16-HDD series IVSS.

December 2018

V1.0.0

First release.

November 2018

Privacy Protection Notice

Foreword II

As the device user or data controller, you might collect personal data of other such as face,
fingerprints, car plate number, Email address, phone number, GPS and so on. You need to be
in compliance with the local privacy protection laws and regulations to protect the legitimate
rights and interests of other people by implementing measures include but not limited to:
providing clear and visible identification to inform data subject the existence of surveillance
area and providing related contact.

About the Manual
















The Manual is for reference only. If there is inconsistency between the manual and the
actual product, the actual product shall prevail.
We are not liable for any loss caused by the operations that do not comply with the
manual.
The manual would be updated according to the latest laws and regulations of related
regions. For detailed information, see the paper manual, CD-ROM, QR code or our
official website. If there is inconsistency between paper manual and the electronic
version, the electronic version shall prevail.
All the designs and software are subject to change without prior written notice. The
product updates might cause some differences between the actual product and the
manual. Please contact the customer service for the latest program and supplementary
documentation.
There still might be deviation in technical data, functions and operations description, or
errors in print. If there is any doubt or dispute, please refer to our final explanation.
Upgrade the reader software or try other mainstream reader software if the manual (in
PDF format) cannot be opened.
All trademarks, registered trademarks and the company names in the manual are the
properties of their respective owners.
Please visit our website, contact the supplier or customer service if there is any problem
occurred when using the device.
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Important Safeguards and Warnings
The following description is the correct application method of the Device. Read the Guide
carefully before use to prevent danger and property loss. Strictly conform to the Guide during
application and keep it properly after reading.

Operating Requirement










Do not place and install the Device in an area exposed to direct sunlight or near heat
generating devices.
Do not install the Device in a humid, dusty or fuliginous area.
Install the Device at stable places horizontally.
Make the Device stay away from liquid.
Install the Device at well-ventilated places; do not block its ventilation opening.
Use the Device only within rated input and output range.
Do not dismantle the Device arbitrarily.
Transport, use and store the Device within allowed humidity and temperature range.

Power Requirement















Be sure to use the designated battery type. Otherwise there may be explosion risk.
Be sure to use batteries according to requirements; otherwise, it may result in fire,
explosion or burning risks of batteries!
To replace batteries, only the same type of batteries can be used.
Be sure to dispose the exhausted batteries according to the instructions.
The product shall use electric wires (power wires) recommended by this area, which
shall be used within its rated specification.
Be sure to use standard power adapter matched with this device. Otherwise, the user
shall undertake resulting personnel injuries or device damages.
Use power supply that meets SELV (safety extra low voltage) requirements, and supply
power with rated voltage that conforms to Limited Power Source in IEC60950-1. For
specific power supply requirements, please refer to device labels.
Products with category I structure shall be connected to grid power output socket, which
is equipped with protective grounding.
Appliance coupler is a disconnecting device. During normal use, keep an angle that
facilitates operation.

Attention
AI module does not support hot plug. If you need to replace the AI module, unplug the
device power cable first. Otherwise, it will lead to file damage on the AI module.
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Overview

1.1 Introduction
Intelligent video surveillance server (IVSS) is compatible with most video surveillance
products. Based on deep learning technology, IVSS has AI functions including human face
recognition, and features extraction.

Supports general system settings, video surveillance, video storage, alarm settings, log
management, record search and playback, intelligent analysis (such as human face
real-time recognition, search human face by specified image and then play back video).

User-friendly interface.

Supports 4K and H.265 decoding, meeting the main development trend of current
market.

Widely used in intelligent building, large parking lot, safe city project, financial planning
area, and so on.

1.2 Login Mode
The device supports local, web and IVSS client operation. For details, see Table 1-1.
Operations and system configurations in the Guide are mainly based on IVSS client. There
might be differences from local or web operation, and the actual interface shall prevail.
Table 1-1 Login mode
Login Mode

Operation
Connect the display, mouse and keyboard to the

Local login

device. View and operate the local menu on the
display.
Connect the device and PC into the same network,

Web login

and remotely access the device through browser
(Google Chrome and Firefox) on PC.

IVSS client
login

Connect the device and PC into the same network,
download and install IVSS Client on PC, and then
remotely access the device with IVSS Client.

Description
Support all functions of the
device.
Support majority functions
of the device, except live
preview, record playback
and video-related function.
Support all functions of the
device.
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The Grand Tour

It is to introduce front panel, rear panel, port function and button function, indicator light status,
and so on.
This section takes 16-HDD for example. For other models, refer to user’s manual.

2.1 Front Panel
Figure 2-1 Font panel with LCD

Figure 2-2 Front panel without LCD

Table 2-1 Front panel description
No.
1

2

Name

Description

Front panel lock

Once the front panel lock is secure, it can prevent HDD from being
stolen or removed by mistake. Unlock the front panel lock and remove
the front panel, you can view 16 HDD slots. See Figure 2-2.

Power on/off
button

Boot up or shut down device. The power on/off button has the
indicator light. It can display device running status.

When device is off (indicator light is off), press the button for a
short period to boot up device.

When device is running, (blue indicator light is on), press the
button for at least 4 seconds to shut down the device.

The Grand Tour
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No.

Name

Description

3

System status
indicator

Displays the system running status.
The blue light is on: Device is running properly.


The indicator light is off: The device is not running.

4

Alarm indicator
light

Displays local input alarm status.

Red indicator light is on: There is local alarm input event.

The indicator light is off: There is no local alarm input event.

5

Network
indicator light

Displays current network status.

The indicator light is blue: It means at least one Ethernet port has
connected to the network.

The indicator light is off: No Ethernet ports are connected to the
network.

6

USB port

Connects to external devices such as USB storage device, keyboard
and mouse.
After you remove the front panel, you can see there are 16 HDDs.
From the left to the right and from the top to the bottom, it ranges from
1–4, 5–8, 9–12, and 13–16.
There are two indicator lights on the HDD slot: HDD indicator light and
HDD read/write indicator light.

7

16-HDD slot


: HDD indicator light. The light is yellow after you install the
HDD.



: Read/write indicator light. The blue light flashes when it is
reading and writing data.

2.2 Rear Panel
Figure 2-3 Rear panel

Table 2-2 Rear panel description
No.

Name

Description

1

Power input
port

Inputs AC 100V-240V power.

The Grand Tour
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No.

2

Name

AI module
indicator light

Description
Displays AI module status.
The yellow light flashes: AI module is running properly.


The yellow light is on: AI module is malfunctioning.
This function is valid if there is AI module.

3

RESET button

Reserved.

HDMI port

High definition audio and video signal output port.
The port outputs the uncompressed high definition video and
multi-channel audio data to the connected display with HDMI port.
The three HDMI ports are different source output.

5

VGA port

VGA video output port. Output analog video signal. It can connect
to the monitor to view analog video. The VGA port and HDMI 1 port
are same source output.

6

RS-232 port

RS-232 COM debug. It is for general COM debug, set IP address,
transmit transparent COM data.

AUDIO IN

Audio input port

AUDIO OUT

Audio output port

8

eSATA port

SATA peripheral port. Connect to SATA port or eSATA device.

9

USB port

Connects to external devices such as USB storage device,
keyboard and mouse.

10

SAS port

SAS extension port. It can connect to the SAS extension controller.

11

Network port

10M/100/1000Mbps self-adaptive Ethernet port. Connect to the
network cable.

4

7

Alarm input

16 groups (1–16) alarm input ports, they are corresponding to
ALARM 1–ALARM 16. The alarm becomes valid in low level.

A and B: Control the A/B cable of the RS-485 device. It is to
connect to the PTZ camera. Connect in parallel 120Ω between
A/B cables if there are too many PTZ decoders.


12

Alarm output

: GND end.

8 groups of alarm output ports (NO1 C1–NO8 C8). Output alarm
signal to the alarm device. Make sure there is power to the external
alarm device.

NO: Alarm output port of Normally Open type.
C: Common alarm output port.



: GND end.
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2.3 Dimensions
Figure 2-4 Dimensions with LCD (mm[inch])
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Figure 2-5 Dimensions without LCD (mm[inch])
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Hardware Installation

This section introduces HDD installation, cable connection, and so on.

WARNING
Some series product is heavy. It needs several people to carry or move jointly to prevent
person injury.

3.1 Installation Flow
Refer to Figure 3-1 for installation flows. Please follow the steps to install.
Figure 3-1 Installation flows

3.2 Unpacking the Box
When you receive the Device, check against the following checking list. If any of the items are
missing or damaged, contact the local retailer or after-sales engineer immediately.
No.

1

Name

Whole
package

Contents
Appearance

There is any visible damage or not.

Package

There is any accidental clash during
transportation or not.

Accessories (list of accessories
on the warranty card)

They are complete or not.

Appearance

There is any visible damage or not.

Device model

The model is the same as ordering
contract or not.
It is torn or not.

2

Device
The label on the device

Do not tear off, or discard the label.
Usually you need to show the serial
number when requiring after-sales
service.

3.3 HDD Installation
The section introduces the detailed operations to install HDD.




If you have not pushed the HDD box to the bottom, do not close the handle to avoid any
damage to the HDD slot.
Different models support different HDD numbers. See the actual situation.

Hardware Installation
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3.3.1 12-HDD Series
Installing HDD

② Place one side of the
①Press the button on the front

HDD

panel of IVSS device, open the

upper side of the box and

handle, and then pull out the

press down to push the

HDD box.

HDD down to the lower side

closely

along

the

③ Insert the HDD box into the
HDD slot, press it to the bottom,
and then close the box handle.

of the mounting surface.

Removing HDD

① Press the button on the
front panel of IVSS device,
open the handle, and then
pull out the HDD box.

② On the back of the HDD
box, press hard on the position
indicated by the arrow.

③

Take out the HDD and

reinsert the box to the slot.
Push it to the bottom and close
the box handle.

3.3.2 16/24-HDD Series
Installing HDD

Hardware Installation
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③ Lock the screws on the back of the
HDD box. Insert the box into the HDD

①Press the button on the
IVSS

② Put the HDD into the

device, open the handle,

box along the direction

and then pull out the HDD

shown in the figure.

front

panel

of

slot, push it to the bottom, and then
close the handle.

In the figure, you only need to lock one

box.

set of the screws (Group A or Group B).
See

the actual situation.

Removing HDD

② Unlock the screws on the
① Press the button on the

back of the HDD box.

front panel of IVSS device,

③ Take out the HDD and
reinsert the box to the slot.

open the handle, and then

The screws are at different

Push it to the bottom and close

pull out the HDD box.

positions for different HDDs.

the box handle.

See the actual situation.

3.4 Connection Diagram
This section takes connecting 16-HDD series device for example. See Figure 3-2. The
connection steps may vary depending on the device, and the actual device shall prevail.

Display, mouse and keyboard are needed for local operation.

Before using the smart detection functions such as face detection and face recognition,
you shall install the AI module first.

Hardware Installation

8

Figure 3-2 Connection diagram

Hardware Installation
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Turning on the Device

CAUTION





Before the boot up, make sure the input voltage matches the device power requirement.
To ensure stable operation of the device and prolong service life of HDD, provide stable
voltage with less ripple interference by reference to international standard.
For device security, connect other cables of the device first, and then connect the device
to the power socket.

Boot-up might vary depending on the model you purchased.

8-HDD series product: Press the power button on the rear panel to boot up device.

For other series products:

Connect to the power socket to boot up device.

After clicking shutdown button on the GUI to turn off the device, press the power
button for a short period of time to boot up device.

Turning on the Device
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5

Initial Settings

For first-time use, you need to initialize the device, set basic information and functions, and
so on.

5.1 Initializing Device
If it is your first time to use the device after purchase or after restoring factory defaults, set a
login password of admin (system default user). At the same time, you can set proper
password protection method.
This section takes web remote initialization for example.
Step 1 Open the browser, input IP address, and click Enter.
The Device initialization interface is displayed. See Figure 5-1.
Default IP address of network port 1 to network port 4 are 192.168.1.108 to
192.168.4.108. Enter the corresponding IP address of the actually connected
network port.
Figure 5-1 Initializing the device

Step 2 Set admin login password. Refer to Table 5-1 for details.
Table 5-1 Description of password parameters
Parameter

Description

User

The default user name is admin.

Password
Confirm
Password

Set admin login password, and confirm the password.
The new password can be set from 8 characters through 32 characters and
contains at least two types from number, letter and special characters
(excluding “'”, “"”, “;”, “:” and “&”). Enter a strong password according to the
password strength indication.

Initial Settings
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Parameter

Description
After setting the prompt, when you move the mouse to

Prompt
question

on the login

interface, the system pops up a prompt to help you remember the password.
The prompt question function is for local login interface only. Refer to the actual
interface for detailed information.

Step 3 Click Next.
The password setting interface is displayed. See Figure 5-2.
Figure 5-2 Password protection

Step 4 Set password protection information. For details, see Table 5-2.
Setting the security questions here, you can use the email you input here or answer
the security questions to reset admin password.



Click

to cancel the email or security questions box.



If the email or security questions box is not set, the password can be reset at
local interface only.
Table 5-2 Password protection

Password protection mode

Description

Email

Set email address. Reset the password through the reserved
email address.

Security question

Set security questions and corresponding answers. Reset
the password through the security question.

Step 5 Click Finish to complete device initialization.
The device initialization success interface is displayed.
Click Enter quick settings to go to the quick setting interface. It is to set device basic
information.

Initial Settings
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5.2 Quick Settings
It is to set system time, and enable NTP function according to your need. After enabling NTP
function, device can automatically synchronize time with the NTP server.
Step 1 Set system time.
1) On initialization interface, click Enter quick settings.
The Time interface is displayed. See Figure 5-3.
Figure 5-3 Time

2) Set system time, date and time zone.
You can set manually or set device to synchronize time with the NTP server.
Step 2 Configure IP address.
Device has 4 Ethernet ports by default. Make sure at least one Ethernet port is connected to
the network before you set IP address.
1) On the Time setting interface, click Next.
The IP Set interface is displayed. See Figure 5-4.

Initial Settings
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Figure 5-4 Set

2) Click

of the corresponding NIC.

The Edit Ethernet Network 1 interface is displayed. See Figure 5-5.

When there is a DHCP server on the network, check Use Dynamic IP
Address, system can allocate a dynamic IP address to the device. There is
no need to set IP address manually.

Check Use Static IP Address. Set static IP address, subnet mask and
gateway. It is to set a static IP address for the device.
Figure 5-5 Edit Ethernet network 1

3) Click OK.
Device goes back to IP Set interface.
4) Set DNS server information and default NIC.
Make sure the default NIC is online.
Step 3 Configure P2P settings.

Initial Settings
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Make sure the system has connected to the network. Otherwise, the P2P function is null.
1) On the IP Set interface, click Next.
The P2P Access interface is displayed. See Figure 5-6. Scan the QR code on the
actual interface.
Figure 5-6 P2P access

2) Click

to enable P2P function.

Step 4 Click Finish to save settings.

5.3 Logging in Device
The system is logged in by default after you initialize the device. Now you can set system
settings and operate.

This section takes logging in IVSS client for example.
Step 1 Download the IVSS installation package.
Open the browser, enter IP address, and click Enter. Click the Click Download to
download IVSS Client installation package. See Figure 5-7.


Initial Settings
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Figure 5-7 Web login interface

Step 2 Double-click the IVSS installation package, and install it according to interface notice.
On completion, the completion interface is displayed. See Figure 5-8.
Figure 5-8 Installation completed

Step 3 Click Run.
The login interface in Step 1is displayed. See Figure 5-9.


System display IVSS Client at full-screen by default. Click
to
display the task column. Enter device IP address, and then press Enter or
click

to login.

Initial Settings
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Figure 5-9 Login

Step 4 Enter device user name and password.
Step 5 Click Login.

5.4 Adding Remote Devices
After you initialize remote device, you can view the live video from the remote device, change
remote device settings, and so on.



Uninitialized device cannot be added. For details, refer to the user’s manual.
This section takes smart add for example.

Step 1 Click

, or click

on Setting interface, and then select Device.

The Device interface is displayed.
Step 2 Click

or Add, and then select Smart Add.

The Smart Add interface is displayed.
Step 3 Click Start Search.
System starts to search and displays result. See Figure 5-10.

Click

to set search criteria.

Initial Settings
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Figure 5-10 Remote device

Step 4 Select a remote device and then click Add.
To add multiple-channel remote device, select the channel that you want to add.
Step 5 Click Continue to add or Finish.

Initial Settings

18

6

Intelligent Operation

AI detection is to process and analyze the video and take the key information, compare the
key information with the preset detection rule and trigger an alarm once the detected
behavior matches the detection rule.
The device supports AI by camera and AI by device.

AI by camera: the camera supports smart detection, such as Smart IPC. The IVSS
device needs to detect and display the intelligent alarm information from the remote
device and use the remote device to set smart detection and record playback.

AI by device: The camera only provides videos and snapshots, but IVSS device supports
smart detection.
When AI by camera is enabled, complete smart detection configuration at remote device. See
remote device user’s manual.

6.1 Enabling AI Plan



AI plan is available on select models.
The interface might vary in respect of AI function, and the actual interface shall prevail.

Step 1 Click

, or click

on Setting interface, and then select Event.

The Event interface is displayed.
Step 2 Select camera in the device tree in the left.
Step 3 Select AI Plan > AI Plan > AI Plan.
The AI Plan interface is displayed.
When the remote device is PTZ and a preset point has been added, the system
configures AI detection function for every preset point. See Figure 6-1.
Figure 6-1 AI plan (1)

Intelligent Operation
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Step 4 Click

to enable AI detection plan. The icon turns into

.

Step 5 Click Save.

6.2 Face Detection
After you configure face detection and face comparison function, the device processes and
analyzes video image, extract face information from the video, and compare it with face
images in the face database.
The device activates an alarm if similarity reaches or exceeds the designated similarity.
The device supports real-time preview of face detection and face comparison information;
searches and plays back video according to face feature.
IVS and face detection function cannot be enabled at the same time.

6.2.1 Setting Face Comparison
Face comparison operation is displayed in Figure 6-2.



Enable AI plan when AI by camera is used.
You cannot search by image when you are using AI by camera and face comparison.
Figure 6-2 Face comparison flow

6.2.2 Configuring Face Database
You can create the face database to save face image, and the intelligent detection function
can trigger the face database to carry out human face comparison, human face search, and
so on. For face database configuration flow, see Figure 6-3.
Figure 6-3 Deleting face database

6.2.2.1 Creating Face Database
Create human face database to sort out and manage the face images uploaded to the device.

Intelligent Operation
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Step 1 On the Live interface, click

, select File > Face database, then click Create.

The Create interface is displayed. See Figure 6-4.
Figure 6-4 Create face database

Step 2 Set Face database name, then click Register face or Save and close.

Click Register face, and then add human face on the newly created human database.
See Figure 6-5. Refer to “6.2.2.2 Adding Face Image” for detailed information.

Intelligent Operation

21

Figure 6-5 Register face



Click Save and close to create a human face database with no data.
After creating face database, you can go to the Face Database interface to view the
newly created face database information. See Figure 6-6 and 0.
Figure 6-6 Face database

Intelligent Operation
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Table 6-1 Description
No.

Description
Click Create to create a face database. For details, refer to “6.2.2.1 Creating Face

1

Database”.

2

Select a face databases, and then click Delete.
Display number and space information of face database.


3

Number: The percentage ratio of the added face image quantity to the allowable total
quantity of face image. Note Device supports maximum 300,000 face images.



Space: The percentage ratio of the created face database quantity to the allowable total
quantity of face database. Human face database creation. Maximum 50 databases.

4

Check All, it is to select all face databases.

5

Display the list of created databases.
Display abstract state.

6
displays face image of current database that failed to abstract.

6.2.2.2 Adding Face Image
Add face images to the created face database in the way of manual add, batch import and
detection.

Preparation






A face image has been obtained, and it meets the following requirements:
The image format is .jpg.


The image size shall be less than or equal to 4MB.

The resolution ranges from 100×100 to 6000×5000.
You have obtained the face image and saved it in the proper path.

When operating on the local interface, save the image in the USB storage device
and then connect the USB storage device to the IVSS device.

When operating on the Web or IVSS interface, save the image on the PC in which
the Web or IVSS client is located.
Before the batch import, name the face image according to the following rule:
“Name#SGender#BBirthday#NNation#PProvince#TIDtype#MIDnumber#AAddress.jpg”
(such as“Tim#S1#B20000101#NCN#PZheJiang#T1#M0000#AAddress”).
Name the face image according to the rule. After successful import, the system will
identify the face image automatically. For details about naming rule, see the user’s
manual.

Operation Steps
Step 1 On the Live interface, click

, select File > Face Database.

Face Database interface is displayed.
Step 2 Double-click face database.
The face database interface is displayed.
Step 3 Click Batch Import.

Intelligent Operation
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The Batch Import interface is displayed. See Figure 6-7.
Figure 6-7 Batch import

Step 4 Import face image.
The system supports uploading file and folder. Select according to your actual need.
Step 5 Click OK.
The batch import result interface is displayed.
Step 6 Click Continue to add or OK.
After adding the image, at the bottom left corner of the face image, there is an icon
. It means device is creating module. Refer to “6.2.2.3 Human Face for detailed
information.
Figure 6-8 Face database

6.2.2.3 Human Face Abstract
The human face abstracting is to abstract the corresponding information of the face image
and import to the database, and then create the human face features module. In this way,
device can compare human face, and search human face.


The greater the face image quantity is, the longer the face abstracting time it takes.

Intelligent Operation
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During the abstracting creation process, some intelligent functions (such as human face
comparison, search human face and so on.) are null. These functions become normal
after the abstracting process is completed.
When the uploaded image is half-length photo or full-body photo, the system
automatically selects the frame of the uploaded image and only the face area will be
retained.

Step 1 On the Live interface, click

, select File > Face Database.

Face Database interface is displayed.
Step 2 Double-click face database.
Face database interface is displayed. See Figure 6-9.
Figure 6-9 Face database interface

Step 3 Select face images and then click Abstract.
System pops up a confirmation box.




Click the All check box, and you can select all face images in the current
human face database.
If there are too many human face images in the human face database, click
to set search conditions (such as name, gender, birthday, country, province,

ID type, ID number or abstracting status) to quickly find the human face images.
Step 4 Click Start Abstract.
Device begins creating module. See Figure 6-10.


The abstracting is successful if

is no longer at the bottom left corner of the

face image. The abstracting may fail if the face image is not clear or does not
contain complete information, and



appears at the bottom left corner of the

face image.
When the uploaded image is half-length photo or full-body photo, the system
automatically selects the frame of the uploaded image and only the face area will
be retained.
Figure 6-10 Abstract result
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6.2.3 Configuring Face Detection
Configure alarm rule of face detection.
Step 1 Click

or click

in the Setting interface, and then select Event.

The Event interface is displayed.
Step 2 Select remote device in the device tree in the left.
Step 3 Select AI Plan > Face Detection.
Face Detection interface is displayed. See Figure 6-11.
Figure 6-11 Face detection

Step 4 Click AI by camera or AI by device, and then click

to enable intelligent function.

AI by camera supports Face RoI function. After enabling Face RoI function, system
displays enhanced human face zone on the surveillance window.
Step 5 Set detection region.
It only supports to set minimum size and maximum size.
1)

Click

, and set detection region in surveillance window. See Figure 6-12.
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Figure 6-12 Area



Press and hold
its range.

or white dot on detect region frame, and drag to adjust



Click

to set human face detection minimum size or maximum

or

size. System triggers an alarm once the detected human size is not larger
than the maximum size or smaller than the minimum size.


2)

Click

Select the motion detect zone you drew. Click

to delete the zone.

to complete the settings.

Step 6 Click Deployment Time to select schedule from the drop-down list.
After setting arm period, system triggers corresponding operations when there is a
motion detection alarm in the specified period.
Step 7 Click Action to set alarm action. Refer to user’s manual for detailed information.
Step 8 Click Save.

6.2.4 Configuring Face Recognition
You can configure face comparison rule. The system compares the detected face image with
face image in the face database, and triggers an alarm when the result conforms to the
comparison rule.
Face detection shall be enabled when AI by device is used. For details, refer to “6.2.3
Configuring Face Detection”.
Step 1 Click

, or click

on Setting interface, and then select Event.

The Event interface is displayed.
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Step 2 Select remote device in the device tree in the left.
Step 3 Select AI Plan > Face Recognition.
Face Recognition interface is displayed. See Figure 6-13.
Figure 6-13 Face recognition

Step 4 Click AI by Camera or AI by Device, and then click

to enable intelligent

function.
Step 5 Click Deployment Time to select schedule from the drop-down list.
After setting deployment period, system triggers actions when there is a motion
detection alarm in the specified period.
Step 6 Set stranger mode.
It is to enable stranger mode. Once the face comparison similarity is lower than the
specified value, system triggers an alarm.
1)

Click

to enable stranger mode.

The Stranger control mode interface is displayed. See Figure 6-14.
Figure 6-14 Stranger control mode

2)

Set parameters. For details, refer to Table 6-2.
Table 6-2 Stranger control mode description

Parameter

Description

AI alarm rule

Click

Show feature panel

Check

to set alarm rule box color.
to enable features panel function. System displays stranger

panel once there is an alarm.

3)

Click Actions to set alarm actions. Refer to user’s manual for detailed
information.
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Step 7 Set triggered face database.

1)

Before you use AI by camera function, go to the remote device to set face
database. At IVSS interface, set alarm event.
Repeat the step to trigger several human databases at the same time.
Click Associate Face Database, and then select the triggered human face
database.
Face database configuration interface is displayed. See Figure 6-15.
Figure 6-15 Face database configuration

2)

Set parameters. For details, refer to Table 6-3.





Table 6-3 Configuration description
Parameter

Description
It is to set human face similarity.

Similar

System compares the human face with the image on the face database, system
triggers an alarm once the similarity reaches threshold you set here.

AI alarm rule

Click

Show feature

Click

panel

to set alarm rule box color.
to enable features panel function. System displays features panel

once there is an alarm.

Click Actions to set alarm actions. Refer to user’s manual for detailed
information.
Step 8 Click Save.
3)

6.2.5 Real-time View
You can view real-time face detection and human face comparison images.

6.2.5.1 Setting AI Display
You can configure display rule of AI detection results.
Before using this function, make ensure that view has been created. Refer to user’s manual
for detailed information.
Step 1 On the Live interface, click

and select Face tab.

The Face interface is displayed. See Figure 6-16.
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Figure 6-16 Face

Step 2 Enable Show Tracking Box and Features Panel, and select feature(s) you want to
display.
Step 3 Click OK to save the configuration.

6.2.5.2 Live
Go to the Live interface, enable view, device displays view video. See Figure 6-17.

The view window displays currently detected face rule box.

The right side displays features panel.

During face detection, features panel displays detection time, the detected face
image and feature.

During face comparison, features panel displays detection time, the detected face
image, face image in the database, comparison result and database name. After
setting stranger mode, when the detected face image mismatches face image in the
database, features panel will have Stranger tag.
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Figure 6-17 Live

6.2.5.3 Face Total
On the Live interface, click

. Face detection panel is displayed. On this interface, you can

view face detection and comparison image, add face image to face database, play back
recorded videos and export them. See Figure 6-18.
Figure 6-18 Detection image

6.2.6 Face Search
Search face detection information, including face detection image, record and features.
Search according to record and image.

6.2.6.1 Search by Attribute
Set event type and attribute, to search qualified face information.
Step 1 On the LIVE interface, click

, select AI Search > Search by Face > By

Attribute.
By Attribute interface is displayed. See Figure 6-19.
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Figure 6-19 Search by attribute

Step 2 Select the remote device, and set event type, face attribute and time.
Step 3 Click Query.
The search results are displayed in the panel. See Figure 6-20.
Figure 6-20 Search result

Click the panel. The operation icons are displayed. See Figure 6-21. For operations of the
icons, see Table 6-4.
Figure 6-21 Icon

Table 6-4 Search by image
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Icon

Operation


Select one by one: Click the panel or move the cursor onto the panel, and then click
to select the panel.



means it is selected.

Batch select: Check All to select all panels on the interface.

Click

to add the image to the face database.

Click

or double-click the panel, the system starts to play back the recorded videos

(about 20s).
Click

or select the panel and click

to export images, videos and Excel to

designated storage path.

After setting alarm linkage snapshot, during exporting images, the system exports detected
images and panoramic images at the time of snapshot.

6.2.6.2 Search by Image
It is to upload face image and then compare with the human face in the record file. Device
can filter the record file in which the human face similarity has reached the threshold.
Device supports to use the face image on the face database or the local face.

When you use face database images to search, ensure face database has been
configured. Refer to "6.2.2 Configuring Face Database" for detailed information.

If you want to use the local images, you need to obtain the face image and saved it in the
corresponding path.

When operating on the local interface, save the image in the USB storage device
and then connect the USB storage device to the IVSS.

When operating on the Web or IVSS interface, save the image on the PC in which
the Web or IVSS client is located.
6.2.6.2.1 Device Search
Upload face image, compare it with face detection result of remote device, and find face
detection information that meets the set similarity.
Step 1 On the LIVE interface, click

, select AI Search > Search by Face > By Image.

The By Image interface is displayed. See Figure 6-22.
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Figure 6-22 Search by image

Step 2 Click Device tab.
Step 3 Upload face image.
Device supports to upload maximum 50 face images. Device supports to select
maximum 10 face images at one time.

Upload the image from the face image database to search corresponding face.
1)

Move the mouse to

and select Face DB.

The Choose Picture From Face DB interface is displayed. See Figure
6-23.
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Figure 6-23 Choose picture from face DB

2)

Select face database and then set search criteria.

If there are too many face images on the database, set name, gender
to filter.


Click

to set the search ID number.

3)



Click Query.
Device displays the searched face images.
4)
Select face image.
The selected face image is displayed on the Chosen Pictures on the right
side.
5)
Click OK to upload face image.
Local image: Upload images from local PC or USB storage device.
1)
2)

Move the mouse to

and select Local.

Select face image you want to upload.

You can select several face images at the same time.
3)
Click OK to upload face image.
After uploading the images, device displays the face images on the top left corner.
The latest 10 images are selected. See Figure 6-24.
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Figure 6-24 By image










When the uploaded image is half-length photo or full-body photo, the system
automatically selects the frame of the uploaded image and only the face area
will be retained.
When there are multiple faces in the uploaded images, the system
automatically identifies the faces in the images and uploads multiple face
images according to the number of faces recognized.
Device supports to select maximum 10 face images.
Click Cancel to cancel all checked face images.
Select Selected only, device displays checked human face images only.
Click Clear to clear all uploaded face images.

Step 4 Hold on and drag

to set human face similarity. It is 80% by default.

Step 5 Select remote device on the device list and then set record file time period.
Step 6 Click Query.
The Result is displayed. See Figure 6-25 and Table 6-5.
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Figure 6-25 Query

Table 6-5 Device search description
No.

Description

1

Displays selected face images. The number at the bottom right of the face image is to
display the searched image amount.
Click one image to view its query result.

2

It is to set filter criteria. It can quickly search the required image according to the face
features.

3

Displays searched schedule list.
Click a date, you can view the image list on current date on the right panel.

4

Displays the searched face panel, including face image, feature attribute and similarity.

Operation
After query, you can play back video file and export. Refer to Table 6-6 for detailed
information.
Table 6-6 Device search operation
Icon

Operation


Select panel

to select the panel.


Playing back
recorded video

Select one by one: Click the panel or move the mouse onto the panel. Click
means it is selected.

Batch select: Click All to select all panels on this page.

Double-click the panel to play back recorded video (about 20s).
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Icon

Operation
Move the mouse to panel and click

, or click the panel and click

to

export images, videos and Excel to designated storage path. Refer to "6.4 IVS"
Export file

for detailed information.

After setting alarm linkage snapshot, during exporting images, the system
exports detected images and panoramic images at the time of snapshot.

6.2.6.2.2 Searching Face Database
Upload face image, compare it with face image in face database, and find face image that
meets the set similarity.
Step 1 On Live interface, click

, select AI Search > Search by Face > By Image >

FaceDB.
The FaceDB interface is displayed. See Figure 6-26.
Figure 6-26 Face database

Step 2 Upload face image. Refer to "6.2.6.2.1 Device Search Step 3" for detailed
information.
Step 3 Hold on and drag

to set human face similarity. It is 80% by default.

Step 4 Select the face database.
Step 5 Click Query.
The Result is displayed. See Figure 6-27 and Table 6-7.
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Figure 6-27 Result

Table 6-7 Description
No.

Description

1

Displays selected face images. The number at the bottom right of the face image is to
display the searched image amount.
Click one image to view its query result.

2

Displays searched schedule list.
Click a date, you can view the image list on current date on the right panel.

3

Displays the searched face panel, including face image, information and similarity.

Operation
Operations include select the panel, and export file. See Table 6-8.
Table 6-8 Face database operation
Name

Operation


Select one by one: Click the panel or move the mouse onto the panel. Click

Select a
to select the panel.

panel


Export file

means it is selected.

Batch select: Select the All check box to select all panels on this page.

Click the panel and click

to export images to designated storage path. Refer

to "6.4 IVS" for detailed information.

6.3 Video Structuring
With video structuring, IVSS can detect, recognize, and extract features from human body,
face, motor vehicle, and non-motor vehicle. For example, features such as gender, age, and
top color can be extracted from human, and you can then search a certain human face or
configure alarm with these features.
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6.3.1 Enabling AI Plan
You need to enable AI plan when AI by camera is used. Refer to "6.1 Enabling AI Plan" to
enable AI detect function.

6.3.2 Configuring Video Structuring
After enabling and then configuring video structuring, IVSS can only link the current remote
device for taking snapshots when alarm is triggered.
This section takes AI by device for example. AI by camera only supports enabling detection
function and setting deployment time.
Step 1 Click

or

, and then select EVENT.

The EVENT interface is displayed.
Step 2 Select a device from the device tree at the left side.
Step 3 Select AI Plan > Video Structuring > AI By Device.
The AI By Device interface is displayed. See Figure 6-28.
Figure 6-28 AI by device

Step 4 Click

next to Feature Vector Extraction to enable feature extraction, then IVSS

can extract features of face and human, such as gender, age, and top color.
Feature vector extraction is available only after Human detection is enabled.
Step 5 Select the detection target.


People: Click

next to Enabled to enable people detection. Face detection

can also be enabled at the same time.


Vehicle: Click corresponding

to enable vehicle detection.
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Non-Motor Vehicle: Click corresponding

to enable non-motor vehicle

detection.
Step 6 Click

(the icon changes to

), then you can configure detection area (orange)

in the video image. See Figure 6-29.


Click any white dot on the frame, and the dot changes to

. Drag

to adjust the

detection area.
Click

to draw an excluded area which will not be detected. IVSS does not

detect target within the excluded area.





Up to 4 excluded areas can be drawn.



To delete an excluded area, select the area, and then click

Click

or

.

to set the minimum size or maximum size of detection target.

Alarm will be triggered when the size of detection target is within the minimum and
maximum sizes.
Figure 6-29 Detection area

Step 7 Click Deployment Time dropdown list to select schedule.
IVSS links alarm event when an alarm is triggered within the schedule configured.


Click Add Schedule to add new schedule if no schedule is added or the existing
schedule does not meet requirements.



Click View Schedule to view details of schedule.

Step 8 Click Save.
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6.3.3 Live
You can view the detected features and properties of face, people, motor vehicle and
non-motor vehicle on the LIVE interface.

6.3.3.1 Setting AI Display
You can set the features and properties that you want to display in the real-time video image
of the LIVE interface.
Before setting the features and properties, you need to create a view by adding cameras to
the view so you can check video and pictures captured by the cameras.
Step 1 Select a view from Live > View > View Group.
Step 2 Click

at the lower side of the LIVE interface, and then select Human, Vehicle or

Non-Motor Vehicle. See Figure 6-30.
The figure takes Human for example. The interface is for reference only, and the
actual interface shall prevail.
Figure 6-30 Human

Step 3 Click

next to Show Tracking Box, then a tracking box is displayed in the video

when target that meets the filtering conditions is detected.
Step 4 Configure feature panel.
4)

Click

next to Features Panel to enable feature panel.
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A features panel is displayed on the right side of the video when target that
meets filtering conditions is detected.
5)

Select the target you want to detect. You can select from Face, Human, Vehicle,
and Non-Vehicle Motor.

6)

(Optional) Drag

to adjust the transparency of panel. The higher the value, the

more transparent the panel.
7)

(Optional) Select the features to be displayed in the panel.


Up to 4 features can be displayed.



4 features are selected by default. To select another feature, click the
selected feature to cancel it, and then click the feature to be displayed.

Step 5 Click OK.

6.3.3.2 Real-time View
You can view the detected features and properties of face, people, motor vehicle and
non-motor vehicle in the real-time video image.
On the LIVE interface, select a view from View Group, and the video image of the view will be
displayed. See Figure 6-31.


Rule box is displayed in real-time in the video image. Different detection targets
correspond to different colors of rule box, and the actual interface shall prevail.



Features panels are displayed on the right side of the video image.
Figure 6-31 Live

Move the cursor to the features panel, and the icons are displayed. See Figure 6-32 or Figure
6-33.
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Figure 6-32 Icons (vehicle detection)

Figure 6-33 Icons (other detection)



Click



Click

to add plate information to plate database.
, or double-click the detected image to play back the video record (10 s before

and after the time of snapshot).


Click

to export images, videos and Excel to designated storage path.

6.3.3.3 Detection statistics
You can view the features and properties of detected human body, face, motor vehicle and
non-motor vehicle.
6.3.3.3.1 Human
You can view the features and properties of detected human body and face.
On the Live interface, click
Click

, the PEOPLE TOTAL interface is displayed.

, and then select Snap With Face and Snap Without Face. The information of

detected human and face is displayed. See Figure 6-34.
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Figure 6-34 Human detection

Move the cursor to a panel, and the following icons are displayed:
: Click it to add the face image to face database.



This function is available when face image is captured.
: Click it, or double-click detected picture to play back the video record (10 s before and



after the time of snapshot).
: Click it to export the video record to specified save path (PC or USB storage device).



If store the video record to USB storage device, make sure the device is connected.
6.3.3.3.2 Motor Vehicle
You can view the features and properties of detected motor vehicles.
On the Live interface, click
Click

, the VEHICLE TOTAL interface is displayed.

, and then select Vehicle Recognition, the information of detected vehicles is

displayed. See Figure 6-35.
Figure 6-35 Motor vehicle detection

Move the cursor to a panel, and the following icons are displayed:

,

and

. Refer to

“6.3.3.3.1 Human” for detailed operation.
6.3.3.3.3 Non-motor Vehicle
You can view the features and properties of detected non-motor vehicles.
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On the Live interface, click
Click

, the NONMOTOR TOTAL interface is displayed.

, and then select Snap With Face and Snap Without Face. The detected

non-motor vehicle features and properties are displayed. See Figure 6-36.
Figure 6-36 Non-motor vehicle detection

Move the cursor to a panel, and the following icons are displayed:

and

. Refer to

“6.3.3.3.1 Human” for detailed operation.

6.3.4 AI Search
Select device and set properties to search detection results. For example, you can set human
properties such as gender, age, top, pants, and search human with these properties.

6.3.4.1 Search by Human
Select device, and set human properties and features, so you can search human with the
defined properties and features.
Step 1 On the LIVE interface, click

, and then select AI SEARCH > Search by Human.

The Search by Human interface is displayed. See Figure 6-37.
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Figure 6-37 Search by human

Step 2 Select device, and set human properties and time period.
Click

or

to set the color.

means more than one color.

Step 3 Click Query.
The search result is displayed. See Figure 6-38.


If face is captured, the human and face snapshots are displayed.



If no face is captured, the human snapshot and human properties are displayed.

Intelligent Operation 47

Figure 6-38 Search result

Other Operations
Click on one displayed panel, and the icons are displayed. See Figure 6-39 or Figure 6-40.
For details, see Table 6-9.
Figure 6-39 Icons (1)

Figure 6-40 Icons (2)

Table 6-9 Operation
Icon

Operation
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Icon

Operation


Select one by one: Click



Select in batches: Select All to select all the panels on the interface.

Click

to select the panel.

means the panel is selected.

or double-click the panel to play back the video record (10 s before and after

the time of taking the snapshot).
Click
Click

to add picture to database.
, or select the panel and then click

to export picture, video, and Excel file to

specified save path.

6.3.4.2 Search by Vehicle
Set event type and vehicle properties to search vehicle detection results. For example, you
can set vehicle properties such as type, logo, plate, and search vehicles with these
properties.
Step 1 On the LIVE interface, click

, and then select AI SEARCH > Search by Vehicle.

The Search by Vehicle interface is displayed.
Step 2 Select device, and then click Property tab.
The Property interface is displayed. See Figure 6-41.
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Figure 6-41 Property

Step 3 Select Vehicle Detection as Event Type.
Step 4 Set vehicle properties and time period.
Click

or

to set the color.

means more than one color.

Step 5 Click Query.
The search result is displayed. See Figure 6-42.
If license plate is detected, both the scenario and the license plate will be displayed.
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Figure 6-42 Search result

Other Operations
Click on one displayed panel, and the icons are displayed. See Figure 6-43. For detailed
operations of icons, see “6.3.4.1 Search by Human.”
Figure 6-43 Icons

6.3.4.3 Search by Non-motor Vehicle
Set event type and non-motor vehicle properties to search non-motor vehicle detection
results. For example, you can set non-motor vehicle properties such as type, color, helmet,
and search non-motor vehicles with these properties.
Step 1 On the LIVE interface, click

, and then select AI SEARCH > Search by NonMotor.

The Search by NonMotor interface is displayed. See Figure 6-44.
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Figure 6-44 Search by non-motor vehicle

Step 2 Select the device you want to search.
Step 3 Set non-motor vehicle properties and time period.
Click

or

to set the color.

means more than one color.

Step 4 Click Query.
The search result is displayed. See Figure 6-45.
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Figure 6-45 Search result

Other Operations
Click on one displayed panel, and the icons are displayed. See Figure 6-46. For detailed
operations, see “6.3.4.1 Search by Human.”
Figure 6-46 Icons

6.4 IVS
IVS is to process and analyze the image, take the key information from the video, compare
the key information with the preset detection rule and trigger an alarm once the detected
behavior matches the detection rule.
IVS type includes cross line detection and cross region detection.
IVS and face detection function of the same remote device cannot co-exist.
IVS scene requirement is as follows:

Total area of the target does not exceed 10% of the image.

Target size in the image shall not be less than 10 pixels × 10 pixels, and leftover target
size shall not be less than 15 pixels × 15 pixels (CIF image). Target height and width
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shall not exceed 1/3 height and width of the image. It is suggested that target height
should be 10% of image height.
Brightness difference of target and background shall not be less than 10 gray levels.
Ensure that the target appears in the field of view for over 2s, movement distance
exceeds target width and shall not be less than 15 pixels (CIF image).
When conditions allow, try to reduce complexity of surveillance analysis scene. It is not
recommended to use IVS in the scene with gathered targets and frequent changes of
light.
Try to avoid glass, reflection of light on the ground and water; try to avoid tree branches,
shadows and areas with mosquito; try to avoid backlight and direct light.

6.4.1 Setting
Set IVS. See Figure 6-47.
Enable AI plan when AI by camera is used.
Figure 6-47 IVS flow

6.4.2 IVS
Set alarm rule of IVS.




The system supports AI by camera and AI by device. When both are enabled, the system
selects AI by device first.
For example, set AI by device.

Step 1 Click

, or click

on Setting interface, and then select Event.

The Event interface is displayed.
Step 2 Select remote device in the device tree in the left.
Step 3 Select AI Plan > IVS Rule.
The IVS Rule interface is displayed.
Step 4 Click AI by device.
The AI by device interface is displayed. See Figure 6-48.
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Figure 6-48 AI by device

Step 5 Set cross line detection and cross region detection rule.
1) Click Add Rule, and select Cross Line Detection or Cross Region Detection.
The rule information is displayed. See Figure 6-49 or Figure 6-50.
Figure 6-49 Configuring cross line detection rules

Figure 6-50 Configuring cross region detection rules

2)

3)

Click

to enable detection rule.

Click

to delete detection rule.

Click

to edit cross line. See Figure 6-51. Click

to edit cross region.

See Figure 6-52.

Hold on
and drag it to adjust position or length of the line and region.

Click
or
on cross line direction to set the direction. An alarm will be
triggered only when the target crosses the line in the designated direction.

Click white dot on the line or region frame to add a turning point. Hold on
on the turning point and drag it to adjust position or length of the line and
region.


Select a line and then click

to delete.
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Figure 6-51 Configuring cross line

Figure 6-52 Configuring cross region

4)

Set cross region action and direction.
Go to this step only when you set cross region.

5)

Click

or

to set minimum size or maximum size of detection target.

System triggers an alarm once the detected target size is not larger than the
maximum size or smaller than the minimum size.
Step 6 AI Recognition
After setting AI recognition, when the system detects a person or vehicle, a rule box
will appear beside the person and vehicle in the surveillance image.
1)

Click

to enable AI recognition function.

The recognition type option displayed. See Figure 6-53.
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Figure 6-53 Type

2)

Select a recognition type.


is to recognize person, and

is to recognize vehicle.

After enabling AI recognition function, at least one recognition type shall be
selected.
Step 7 Click Deployment Time to select schedule from the drop-down list.
After setting deployment period, system triggers corresponding operations when
there is a motion detection alarm in the specified period.

Click View Schedule to view detailed schedule settings.

If the schedule is not added or the added schedule does not meet actual needs,
click Add Schedule.
Step 8 Click Actions to set alarm action. Refer to user’s manual for detailed information.


Repeat Step 5-Step 8 to add multiple detection rules. Support to add max. 10
detection rules at the same time.
Step 9 Click Save.

6.4.3 Real-time View
On the Live interface, view real-time IVS results.

6.4.3.1 Live
Go to the Live interface, enable view, device displays view video. See Figure 6-54.

When a target triggers cross line or cross region rule, the line or region frame in the view
flickers in red.

After setting AI recognition, when the system detects a person or vehicle, a rule frame
will appear beside the person and vehicle in the view.

There is a feature panel on the right side of the video window.
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Figure 6-54 Live

6.4.3.2 Detection Statistics
On the Live interface, click

. Person detection panel is displayed. See Figure 6-55. Click

. The vehicle detection panel is displayed. See Figure 6-56.
Figure 6-55 People total

Figure 6-56 Vehicle total

On this interface, you can view IVS detection image, play back recorded videos and export
them.
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6.4.4 Search Interface
After query of AI detection information, export the results to designated storage path. The
exported detection result can include image, record and feature attribute.




Connect USB device to the system if you are on the local menu to operate.
Take exporting human detection information for example.
After setting alarm linkage snapshot, during exporting images, the system exports
detected images and panoramic images at the time of snapshot.

Step 1 On the Live interface, click

and then select AI Search > IVS.

Step 2 Select the remote device, and set event type, effective target and time.
Step 3 Click Query.
The search results are displayed in the panel. See Figure 6-57.
Figure 6-57 Search result

Step 4 Select multiple panels.
Check All to select all panels on this page.
Step 5 Click

and select file format. See Figure 6-58.
Figure 6-58 File format

Step 6 Click OK.
The Export interface is displayed. See Figure 6-59.
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Figure 6-59 Export

Step 7 Click Browser to select save path.
Step 8 Click OK.
The system exports files to designated path and displays Export Progress interface.
Step 9 Click OK to complete the settings.

6.5 Vehicle Comparison
IVSS compares the detected vehicle properties with plate pictures of linked plate database,
and then triggers alarm when the matched similarity reaches or exceeds the defined
similarity.

6.5.1 Procedure
The procedures of setting vehicle comparison are shown in Figure 6-60 and Figure 6-61.
Figure 6-60 Vehicle comparison procedure (AI by camera)
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Figure 6-61 Vehicle comparison procedure (AI by IVSS)
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6.5.2 Enabling AI Plan
Before using AI by camera, AI plan needs to be enabled first. For details, see "6.1 Enabling AI
Plan."

6.5.3 Setting Vehicle Database
Set vehicle database, and then IVSS can analyze and compare vehicle plates with
information in the database.

6.5.3.1 Creating Vehicle Database
You can create vehicle database, and then classify and manage the database. Database of
trusted vehicle list and blocked vehicle list can be created. Alarm will be triggered when
vehicle in the blocked list is detected.
Step 10 On the LIVE interface, click

, and then select FILE > Vehicle Management >

Vehicle Database.
The Vehicle Database interface is displayed. See Figure 6-62.
Figure 6-62 Vehicle database

Step 11 Click Create Vehicle DB.
The Create Vehicle DB interface is displayed. See Figure 6-63.
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Figure 6-63 Create vehicle database

Step 12 Set Vehicle DB Name, and select Type of vehicle database.
Step 13 Click Register Vehicle or Save and close.

Click Register Vehicle, and add the vehicle information to the database. See
Figure 6-64. For details, see "6.5.3.2 Registering Vehicle Information."
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Figure 6-64 Register vehicle plate

Click Save and close to create a database without editing its information.
The newly-created database can be viewed on the Vehicle Database interface. See
Figure 6-65.
Figure 6-65 Vehicle database


Other Operations
Operations after a database is created include modifying the database name, registering
plate information, arming the database, and deleting the database. See Table 6-10.
Table 6-10 Other operations
Operation

Description
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Operation

Description


View database

: Database name.



: Number of vehicle plate in the database.

information and
status



/



: The database is in the blocked/trusted list.
: The database is not linked to channel for vehicle plate

comparison. If armed, the linked device channel will be displayed.
Modify database
name

Click

next the database name to modify its name.

Double-click the database, and you can manage the vehicle plate
Manage database

information in the database. For details, see "6.5.3.3 Managing Vehicle
Information."

Arm database

Link the database to camera channel for vehicle plate comparison. For
details, see "6.5.4 Setting Plate Comparison."


Delete one by one: Move the cursor to the database, and click

at the

upper right corner to delete it.


Delete database

Delete in batch: Move the cursor to a database, and check

to

select the database. Select multiple databases in this way, and then
click


to delete the selected databases.

Delete all: Select All, and then click

to delete all

databases.

6.5.3.2 Registering Vehicle Information
Add vehicle information in the created databases. Supports manual add, batch import, and
add by searching.
This section takes batch add for example. Batch add allows you to import vehicle information
to the database in batches.
Step 1 On the LIVE interface, click

, and then select FILE > Vehicle Management >

Vehicle Database.
The Vehicle Database interface is displayed.
Step 2 Double-click the database.
The database interface is displayed.
Step 3 Click Batch Import.
The Batch Import interface is displayed. See Figure 6-66.
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Figure 6-66 Batch import

Step 4 Acquire and fill in the template file.
1) Click Download Template to download the template to PC or USB storage
device.
The save path may vary when operating on client or local interface, and the
actual interface shall prevail.


On client: Click

on the upper right side, and then select



to view the save path of template file.
On local interface: Select the save path of template file.

Make sure USB storage device is connected during local operation.

On web interface: Template file is saved in the default download path of
browser.
2) Fill in the template fill according to your actual needs. See Figure 6-67.
Fill in the vehicle information according to the instructions. For logo, type, color,
and plate color, fill in the corresponding code or value. Search the code or value
on the Batch Import interface (See Figure 6-66).
Figure 6-67 Template file

3) Save template file.
Step 5 On the Batch Import interface, click Browse to import template file.
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If the plate number in the template is the same as the number in the database, select
Replace Data to overlap the information in the database.
Step 6 Click OK.
The batch import result is displayed. See Figure 6-68.
Figure 6-68 Batch import result

Step 7 Click Add More or OK.

Click Add More: Import vehicle information, and continue to add vehicle
information.

Click OK: Import vehicle information.
The added vehicle information can be viewed on the Vehicle Database interface.
See Figure 6-69.
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Figure 6-69 Vehicle information

6.5.3.3 Managing Vehicle Information
After adding the vehicle information, such as plate, vehicle type, vehicle color, plate color,
logo, to the database, the information needs to be properly managed and maintained to keep
it accurate and complete.
On the LIVE interface, click

, and then select FILE > Vehicle Management > Vehicle

Database. The database interface is displayed. See Figure 6-70.
Move the cursor to the database, and then

,

, or

to edit, copy/cut, or delete the

vehicle information.
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Figure 6-70 Database

6.5.4 Setting Plate Comparison
IVSS compares detected plate with plate information in the database, and trigger alarms
when plate in the vehicle blacklist is detected.
The section takes AI by device for example, and the actual interface shall prevail.
Step 1 Click

or

on the setting interface, then select EVENT.

The EVENT interface is displayed.
Step 2 Select device from the device tree on the left side.
Step 3 Select AI Plan > Plate Comparison.
The Plate Comparison interface is displayed. See Figure 6-71.
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Figure 6-71 Plate comparison

Step 4 Click

to enable plate comparison. The icon changes to

.

Step 5 Click Deployment Time dropdown list to select schedule.
IVSS links alarm event when an alarm is triggered within the schedule configured.


Click Add Schedule to add new schedule if no schedule is added or the existing
schedule does not meet requirements.


Click View Schedule to view details of schedule.
Step 6 Link vehicle without database.
Enable linkage of vehicle without database. Alarm is triggered when vehicle not in the
database is detected.

1)

Click

.

The Associate Vehicle Without Database interface is displayed. See Figure
6-72.
Figure 6-72 Associate vehicle without database

2)

Click Actions to set alarm linkage event.
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Step 7 Link database.
Repeat the following steps to link multiple databases.
1) Click Associate Vehicle Database, and select the database to be linked.
The database linkage interface is displayed. See Figure 6-73.
Figure 6-73 Database linkage

2)

Set the parameters. See Table 6-11.
Table 6-11 Database linkage parameters

Parameter

Description

AI Alarm Rule

Click

Show Feature

Click

Panel

to set the color of alarm rule box.
, and when alarm is triggered, the plate comparison information is

displayed in the feature panel of video image.

3) Click Actions to set alarm linkage event.
Step 8 Click Save.

6.5.5 Real-time View
View vehicle comparison results on the LIVE interface.
You can view real-time vehicle comparison results on the LIVE interface. If vehicle in the
database is detected, properties of the vehicle, such as plate, type, color, and logo, are
displayed on the right side of the real-time video image.

6.5.5.1 Setting AI Display
You can set the vehicle properties that you want to display on the real-time video image.
Before setting the features and properties, you need to create a view by adding cameras to
the view so you can check video and pictures captured by the cameras.
Step 1 Select a view from LIVE > View > View Group.
Step 2 Click

, and then select Vehicle tab.

The Vehicle interface is displayed. SeeFigure 6-74.
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Figure 6-74 Vehicle

Step 3 Click

next to Show Tracking Box to enable tracking box function.

A tracking box is displayed in the video image when target meeting detection rule is
detected.
Step 4 Set features panel.
1)

Click

next to Features Panel to enable features panel function.

Features panel will be displayed at the right side of video image when target with
selected features is detected.
2) Select a vehicle information panel.
means the panel is selected.
3)

(Optional) Drag

to adjust the transparency of panel. The higher the value, the

more transparent the panel.
4)

(Optional) Select the features to be displayed in the panel.


Up to 4 features can be displayed.



4 features are selected by default. To select another feature, click the
selected feature to cancel it, and then click the feature to be displayed.

Step 5 Click OK.

6.5.5.2 Live
On the LIVE interface, select a view, and the video image of the view is displayed. See Figure
6-75.
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Tracking box is displayed in the video image.
Features panel is displayed at the right side of the video image.
Figure 6-75 Live

Move the cursor to the features panel, and the operation icons are displayed. See Figure
6-76.
Figure 6-76 Icons



Click

to add license plate information to the plate database.



Click

or double-click the vehicle image to play back the video image (10 s before

and after the time of taking the snapshot).

6.5.5.3 Detection Statistics
You can view the vehicle comparison results. For example, you can view whether a vehicle is
in the blacklist database or whitelist database.
On the LIVE interface, select a view and then click

. The VEHICLE TOTAL interface is

displayed.
Click

, and then select Vehicle Comparison (Black List) and Vehicle Comparison

(White List). The vehicle comparison result is displayed. See Figure 6-77.
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Figure 6-77 Vehicle comparison

Move the cursor to the information panel, and the following icons are displayed:


: Click it to add license plate information to plate database.



: Click it or double-click the picture to play back the video image (10 s before and after
the time of taking the snapshot).



: Click it to export the video to specified save path (PC or USB storage device).

Make sure USB storage device is connected if you want to store the file to such storage
device.

6.5.6 AI Search
Set search conditions such as device and properties, and then search information that meets
the conditions. IVSS supports search by property and search by database.

6.5.6.1 Search by Property
Set search conditions such as device and properties, and then search vehicle recognition
information that meets the conditions.
Step 1 On the LIVE interface, click

, and then select AI Search > Search by Vehicle.

The Search by Vehicle interface is displayed.
Step 2 Select device, and then click Property tab.
The search by property interface is displayed. See Figure 6-78.
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Figure 6-78 Search by property

Step 3 Select Plate Comparison as the Event Type.
Step 4 Set vehicle properties and time period.
Click

or

to set the color.

means more than one color.

Step 5 Click Query.
The search result is displayed. See Figure 6-79.
If license plate is detected, both the scenario and the license plate will be displayed.
Figure 6-79 Search result

Other Operations
Click on one displayed panel, and the icons are displayed. See Figure 6-80. For operation
details of icons, refer to “6.5.5.3 Detection Statistics.”
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Figure 6-80 Icons

6.5.6.2 Search by Database
Search vehicle recognition information according to database.
Step 1 On the LIVE interface, click

, and then select AI Search > Search by Vehicle.

The Search by Vehicle interface is displayed.
Step 2 Select device from the device tree, and then click Vehicle DB tab.
The search by database interface is displayed. See Figure 6-81.
Figure 6-81 Search by vehicle database

Step 3 Select the database to be searched.
Step 4 Click Query.
The search result is displayed. If license plate is detected, both the scenario and the
license plate will be displayed.

Other Operations
Click on one displayed panel, and the icons are displayed. For operation details of icons,
refer to “6.5.5.3 Detection Statistics.”
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7

Logout/Reboot/Shut Down

You can log out, reboot and shutdown the device. See Figure 7-1.
Figure 7-1 User operation

Log Out
Click

, and then select Log Out.

Reboot
Click

, and then select Reboot. System pops up confirm dialogue box. Click OK to

reboot.

Shut Down
CAUTION
To unplug the power cable may result in data (record, image) loss. We recommend Mode 1.






Mode 1 (recommended): Click

, and then select Shut Down. System pops up

confirm dialogue box, and then click OK to shut down.
Mode 2: Use power on/off button on the device.

8-HDD series product: Press power on/off button on rear panel.

Other series products: Press the power on/off button on the device for at least 4
seconds.
Mode 3: Unplug the power cable.

Logout/Reboot/Shut Down

76

Appendix 1 Cybersecurity Recommendations
Cybersecurity is more than just a buzzword: it’s something that pertains to every device that
is connected to the internet. IP video surveillance is not immune to cyber risks, but taking
basic steps toward protecting and strengthening networks and networked appliances will
make them less susceptible to attacks. Below are some tips and recommendations on how to
create a more secured security system.
Mandatory actions to be taken for basic equipment network security:
1. Use Strong Passwords
Please refer to the following suggestions to set passwords:

The length should not be less than 8 characters;

Include at least two types of characters; character types include upper and lower
case letters, numbers and symbols;

Do not contain the account name or the account name in reverse order;

Do not use continuous characters, such as 123, abc, etc.;

Do not use overlapped characters, such as 111, aaa, etc.;
2. Update Firmware and Client Software in Time

According to the standard procedure in Tech-industry, we recommend to keep your
equipment (such as NVR, DVR, IP camera, etc.) firmware up-to-date to ensure the
system is equipped with the latest security patches and fixes. When the equipment
is connected to the public network, it is recommended to enable the “auto-check for
updates” function to obtain timely information of firmware updates released by the
manufacturer.

We suggest that you download and use the latest version of client software.
"Nice to have" recommendations to improve your equipment network security:
1. Physical Protection
We suggest that you perform physical protection to equipment, especially storage
devices. For example, place the equipment in a special computer room and cabinet, and
implement well-done access control permission and key management to prevent
unauthorized personnel from carrying out physical contacts such as damaging hardware,
unauthorized connection of removable equipment (such as USB flash disk, serial port),
etc.
2. Change Passwords Regularly
We suggest that you change passwords regularly to reduce the risk of being guessed or
cracked.
3. Set and Update Passwords Reset Information Timely
The equipment supports password reset function. Please set up related information for
password reset in time, including the end user’s mailbox and password protection
questions. If the information changes, please modify it in time. When setting password
protection questions, it is suggested not to use those that can be easily guessed.
4. Enable Account Lock
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5.

6.

7.

8.

9.

10.

11.

12.

13.

14.

The account lock feature is enabled by default, and we recommend you to keep it on to
guarantee the account security. If an attacker attempts to log in with the wrong password
several times, the corresponding account and the source IP address will be locked.
Change Default HTTP and Other Service Ports
We suggest you to change default HTTP and other service ports into any set of numbers
between 1024~65535, reducing the risk of outsiders being able to guess which ports you
are using.
Enable HTTPS
We suggest you to enable HTTPS, so that you visit Web service through a secure
communication channel.
Enable Whitelist
We suggest you to enable whitelist function to prevent everyone, except those with
specified IP addresses, from accessing the system. Therefore, please be sure to add
your computer’s IP address and the accompanying equipment’s IP address to the
whitelist.
MAC Address Binding
We recommend you to bind the IP and MAC address of the gateway to the equipment,
thus reducing the risk of ARP spoofing.
Assign Accounts and Privileges Reasonably
According to business and management requirements, reasonably add users and assign
a minimum set of permissions to them.
Disable Unnecessary Services and Choose Secure Modes
If not needed, it is recommended to turn off some services such as SNMP, SMTP, UPnP,
etc., to reduce risks.
If necessary, it is highly recommended that you use safe modes, including but not limited
to the following services:

SNMP: Choose SNMP v3, and set up strong encryption passwords and
authentication passwords.

SMTP: Choose TLS to access mailbox server.

FTP: Choose SFTP, and set up strong passwords.

AP hotspot: Choose WPA2-PSK encryption mode, and set up strong passwords.
Audio and Video Encrypted Transmission
If your audio and video data contents are very important or sensitive, we recommend
that you use encrypted transmission function, to reduce the risk of audio and video data
being stolen during transmission.
Reminder: encrypted transmission will cause some loss in transmission efficiency.
Secure Auditing

Check online users: we suggest that you check online users regularly to see if the
device is logged in without authorization.

Check equipment log: By viewing the logs, you can know the IP addresses that were
used to log in to your devices and their key operations.
Network Log
Due to the limited storage capacity of the equipment, the stored log is limited. If you need
to save the log for a long time, it is recommended that you enable the network log
function to ensure that the critical logs are synchronized to the network log server for
tracing.
Construct a Safe Network Environment
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In order to better ensure the safety of equipment and reduce potential cyber risks, we
recommend:

Disable the port mapping function of the router to avoid direct access to the intranet
devices from external network.

The network should be partitioned and isolated according to the actual network
needs. If there are no communication requirements between two sub networks, it is
suggested to use VLAN, network GAP and other technologies to partition the
network, so as to achieve the network isolation effect.

Establish the 802.1x access authentication system to reduce the risk of
unauthorized access to private networks.
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